---
title: How to Fix Quickbooks Errors H202, H101
description: Quickbook errors H202 and H505 occur when you try to switch to multi-user mode, but something is interfering with the connection to the server.
---

[Skip to content](https://kb.vsystems.com/how-to-fix-quickbooks-errors-h202-h101#main-content)

English

Show submenu for translations

![VSystems\_Decked\_Grey\_4col-1.png\]](https://kb.vsystems.com/hs-fs/hubfs/VSystems_Decked_Grey_4col-1.png?height=40&name=VSystems_Decked_Grey_4col-1.png)

- [Home](https://www.vsystems.com/)
- [About Us](https://www.vsystems.com/about/)
- [Contact Us](https://www.vsystems.com/contact/)

Open main navigation

Close main navigation

- [Home](https://www.vsystems.com/)
- [About Us](https://www.vsystems.com/about/)
- [Contact Us](https://www.vsystems.com/contact/)
- English
  
  Show submenu for translations
- Contact us

 Contact us

 Hello. How can we help you?

- There are no suggestions because the search field is empty.

1. [Help Center](https://kb.vsystems.com/?hsLang=en)
2. [Quickbooks Hosting](https://kb.vsystems.com/quickbooks-hosting?hsLang=en)

# How to Fix Quickbooks Errors H202, H101

## Quickbook errors H202 and H505 occur when you try to switch to multi-user mode, but something is interfering with the connection to the server.

**How to Resolve Error H202**

Error code H202 warns you that “This company file is on another computer, and QuickBooks needs some help connecting.”

 

The first step in fixing Error H202 depends on how you host your company files.

If you host on your own computer, you should have followed the steps to install [QuickBooks Database Server Manager](https://quickbooks.intuit.com/learn-support/en-us/configure-for-multiple-users/install-quickbooks-database-server-manager/00/203290) on your server for each QuickBooks version you use.

You can either set up the database server manager with:

- The full program option, where you install the full version of QuickBooks Desktop and Database Server Manager on your computer.
- The server only option, in which you only install Database Server manager.

You may also host with [Windows Server 2012 Essentials R2](https://quickbooks.intuit.com/learn-support/en-us/install-new-products/how-to-fix-error-h202-if-you-use-windows-server-2012-essentials/00/289722) to host your network or with another hosting solution. In this case, don’t follow the steps below

 

Now follow these steps to troubleshoot:

 

1. **First Try to Resolve the Issue by Running the QuickBooks Database Server Manager**

- Close QuickBooks
- Download the most recent version of the [QuickBooks Tool Hub](https://dlm2.download.intuit.com/akdlm/SBD/QuickBooks/QBFDT/QuickBooksToolHub.exe).
- Save the file somewhere you can find it easily, then open the file.
- Follow the instructions to install, then open the tool hub
- Now, run the QuickBooks Database Server Manager on your server
- From the tools hub, click **Network Issues.**
- Inside the Database Server Manager, click **Start Scan** if you see your company’s files, otherwise choose **Browse** to locate them, then click **Start Scan.**
- The Database Server Manager will repair firewall permission automatically. When the scan is complete, click
- Now, open QuickBooks on each workstation that had error code 202. Select **File**, then **Switch to Multi-User Mode**. If you use the server as a workstation, check it also.

If you still see the error code, move on to the next step.

 

1. **Check the services on your server.**

- Before you begin, if you use the Full Program option, first turn on multi-user hosting. In the **File** menu, select **Utilities**, If **Host Multi-User Access** appears as an option, choose it.
- Now, make sure QuickBooks services are running on your server:
- Open the Windows **Start Menu**, type **Run** in the search bar and open **Run**.
- Type **msc** in the **Run** window and click **Enter.**
- Double-clickNote: .XX stands for your version of QuickBooks.
- Click **Automatic** for the Startup Type.
- Service status should be Running or Started – if not, click **Start**

 **![Picture1-4](https://kb.vsystems.com/hs-fs/hubfs/Picture1-4.png?width=688&height=419&name=Picture1-4.png)**

 

- Select the **Recovery**
- Click **Restart the Service** from each of the following drop-down menus
- First failure
- Second failure
- Subsequent failure

![Picture2-1](https://kb.vsystems.com/hs-fs/hubfs/Picture2-1.png?width=688&height=419&name=Picture2-1.png)

- Click **Apply**, then select
- Repeat the steps for the QBCFMonitorService.

 

If you still get Error H202, try the third step.

1. **Add services to your Windows Admin Group**

- Make sure you’ve given QuickBooksDBXX and QBCFMonitorService administrative permissions on your server. See this [QuickBooksHelp article](https://quickbooks.intuit.com/learn-support/en-us/multi-user-mode/set-up-folder-and-windows-access-permissions-to-share-company/00/201880) for more information.
- Now, Open QuickBooks on your server and workstations.

If you still get error H202, try step 4.

 

1. **Configure firewall settings on your server.**

- See instructions from QuickBooks on [configure Firewall and Internet security settings for QuickBooks Desktop](https://quickbooks.intuit.com/learn-support/en-us/access-data-remotely/set-up-firewall-and-security-settings-for-quickbooks-desktop/00/201468)
- After setting up firewall permission, open QuickBooks on workstations.
- Select the **File** menu and click **Switch to Multi-User Mode**.

 

If you still see error H202, move on to step 5.

1. **Check your connection to the server from a workstation receiving the error.**

- Turn on Network Discovery on your computer and workstations with the error.
- Open the Windows Start menu on your server and the workstations.
- Enter **Network** into search and open **Network and Sharing Center**.
- Select Change advanced sharing settings.
- Ensure **Turn on network discovery** is selected in the Network Discovery and File and printer sharing.

Now find your server name:

- Open the Windows Start menu on the server
- Type **Run** into search and open **Run**.
- Type **CMD** into the Run window and click **Enter**.
- Type **ipconfig/all** into the CMC window and click **Enter**.
- Find the host name in the Windows IP Configuration section. The server name is on the right.

![Picture3](https://kb.vsystems.com/hs-fs/hubfs/Picture3.png?width=624&height=374&name=Picture3.png)

Write the host name or copy it to a doc so you can access it easily.

At your workstation, open the Windows Start menu.

Type **Run** into search and open **Run**.

Type **CMD** into the Run window and click **Enter**.

Type **ping \[your server name\]** and click **Enter**.

![Picture4](https://kb.vsystems.com/hs-fs/hubfs/Picture4.png?width=624&height=30&name=Picture4.png)

If there is packet loss or a very slow reply, contact an IT professional for help, otherwise, your server -workstation connection is fine, and you can move on to the next step.

 

1. **Add your server to your Windows hosts file.**

[Contact QuickBooks](https://help.quickbooks.intuit.com/en_US/contact) for instructions.

If this step doesn’t resolve error H202, contact Virtual Systems for additional guidance.

 

 

**How to Resolve Errors H101, H303, H505**

When these error codes appear, one or more of your workstations are set as the server for QuickBooks. Only your server should be the computer that hosts QuickBooks, and it should be set to multi-user mode.

**Host Multi-User Access** should be turned off on workstations.

Open QuickBooks on any workstation where you see error code H101, H303, H505.

Select the **File** menu and hover over **Utilities**.

If you see **Host Multi-User Access**, don’t select it. Repeat for each workstation until you locate the one creating the issue. When you find a workstation where you see Stop Hosting **Multi-User Access** select it.

![Picture5](https://kb.vsystems.com/hs-fs/hubfs/Picture5.png?width=624&height=374&name=Picture5.png)

Repeat these steps on all workstations that have the error.

 

Once you’ve checked all workstations, check the server:

- Open QuickBooks on your server.
- Open the **File**menu and hover over
- If **Host Multi-User Access**appears, select it. If **Stop Hosting Multi-User Access** is an option, don’t select it.

 

 

- [Backup and Disaster Recovery](https://kb.vsystems.com/backup-and-disaster-recovery?hsLang=en#main-content)

    - [Hystax](https://kb.vsystems.com/backup-and-disaster-recovery?hsLang=en#hystax)
    - [Veeam](https://kb.vsystems.com/backup-and-disaster-recovery?hsLang=en#veeam)
- [Backup for Microsoft 365](https://kb.vsystems.com/backup-for-microsoft-365?hsLang=en)
- [Quickbooks Hosting](https://kb.vsystems.com/quickbooks-hosting?hsLang=en)
- [Reseller](https://kb.vsystems.com/reseller?hsLang=en)
- [Veeam Data Cloud](https://kb.vsystems.com/veeam-data-cloud?hsLang=en)
- [Virtual Private Server](https://kb.vsystems.com/virtual-private-server?hsLang=en)

- [Home](https://www.vsystems.com/)
- [About Us](https://www.vsystems.com/about/)
- [Contact Us](https://www.vsystems.com/contact/)

www.vsystems.com Help Center

Copyright © 2025, Virtual Systems